Viktor's Supportboard
Quickmenü
» Start
» Portal
» Kontakt
» Mitglieder
» Team

» Handy-Ansicht


Usermenü

» Registrieren

Login
Benutzername:
Passwort:

(Passwort vergessen?)

Database
» Database

Lizenzshop/Verwaltung
» Lizenzshop/Verwaltung


Allgemeines
» Themen der letzen 24 Stunden
» Beiträge von Heute
» Aktuelle Umfragen
» Themen als gelesen markieren
» Themen ohne Antwort

» F.A.Q
» Regeln
» Impressum
» Datenschutzerklärung

» Linkliste
» Partner
» Statistik

Kostenplichtige Hacks
» VG-Lizenz
» VG-Fotowettbewerb
» VG-Kontaktanzeige
» VG-Literatur-Verwaltung
» VGTreffen/Dater
» VGMusik/Video

Mein Hacks
» VGUser-Leaflet-Map
» VGUser-Google-Map
» VGClub-Map-Google
» User-Map
» Club-Map
» User-Locator
» Club-Locator
» Mitglieder Bilderupload
» VGOnlineList
» Teamspeak Onlineanzeige

Meine Banner
» Meine Banner

Statistik
Beiträge: 144.931 (Täglich: 18,95 )
Themen: 16.806
Mitglieder: 13.209
Neuestes Mitglied: zitronentee.
Ausl. d. letzten Minute: 206%
Ausl. d. letzten 5 Minuten: 271%
Ausl. d. letzten 15 Minuten: 394%
Aktulle Uhrzeit: 06:09
Freier Webspace: 4.14 TB
PHP-Version: 7.4.33

Spenden

Partner
Mein Supportboard

MySQLDumper

Forum für Angehörige und Freunde von Krebspatienten

Wetter-Board

Make your Webserver

ABC-des Essens

IC-Netforum

ultimate-funultimate-fun

Steinadler-Bastelstübchen

Webseitenschutz
Yukon Tramps & Drivers

Werben

Viktor's Supportboard » Support für das wBB1.1, wBB1.2 und wBB Lite » Fragen/Hilfe/Sonstiges (wBB Lite 1.0) » Modal als BBCode » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): « vorherige 1 [2] Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Modal als BBCode
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey,

Der Abstand ist jetzt weg, vielen Dank. großes Grinsen


Bzgl. dem max-width Anpassen muss ich mal noch überlegen und darüber schlafen, ob sich das wirklich lohnt. Momentan bin ich zu kaputt, um das noch zu kapieren. Jetzt bin ich nur schon einmal überglücklich, dass überhaupt alles fehlerfrei funktioniert, das hätte ich vorgestern nie gedacht, dass das so schnell funktioniert. Ich werd auch mal noch schauen, was meine Forenpartnerin dazu meint, ob es das überhaupt braucht, da wir die Image-Form ziemlich sicher seltener brauchen als die Link-Form.


Nochmals vielen vielen Dank und falls ich mich irgendwie erkenntlich zeigen kann, sag es ruhig. großes Grinsen
29.08.2023 21:52 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Schrimm
Spezialist



Dabei seit: 16.03.2015
Beiträge: 770
12 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 9,89

Level: 42 [?]
Erfahrungspunkte: 2.630.414
Nächster Level: 3.025.107

394.693 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

Schön, dass soweit alles funktioniert.
Eventuell möchtest du der Klasse ".modallabelimg" noch ein "vertical-align: middle" hinzufügen.
Jedenfalls nur eine Spielerei...

__________________

29.08.2023 21:54 Schrimm ist offline Beiträge von Schrimm suchen Nehmen Sie Schrimm in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey,

Da werden wir wahrscheinlich noch schauen müssen, ob wir die alle in der Mitte brauchen oder nicht, ansonsten würde es wohl auch mit dem center-BBCode gehen.
Vielen Dank für die gute Idee, ich werd's mir merken. Freude
29.08.2023 22:06 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey,

mir ist gerade noch ein ziemlich merkwürdiger Fehler über den Weg gelaufen.

Wenn in einem Thread in mehreren Beiträgen Modale verwendet werden, werden nicht die korrekten Bilder angezeigt.

Beispiel:
  • In Beitrag 1 hat es 2 Link-Modale. Beide Modale werden korrekt angezeigt.
  • In Beitrag 2 hat es 4 Link-Modale. Bei den ersten beiden werden die Bilder von Beitrag 1 angezeigt, das dritte und das vierte werden korrekt angezeigt.
  • In Beitrag 3 hat es 6 Link-Modale. Bei den ersten beiden werden die Bilder von Beitrag 1 angezeigt, bei den nächsten beiden werden die Bilder von Beitrag 2 angezeigt, die letzten beiden werden korrekt angezeigt.

Bei den Image-Modalen ist es das gleiche, allerdings sind die Vorschauen korrekt.

Wenn man einen der Beiträge editiert und die Modale in der Vorschau anschaut, sind alle Bilder korrekt.

Wenn in einem Beitrag ein Link-Modal ist und im nächsten ein Image-Modal ist, dann ist alles korrekt.

Könnte da noch irgendwo ein Fehler im Code sein? verwirrt

Die "class_parse.php" und die "bbcode.js" hab ich mal angefügt, damit hier die aktuellsten Versionen sind.

Dateianhänge:
txt bbcode.js.txt (11 KB, 2 mal heruntergeladen)
txt class_parse.php.txt (14,25 KB, 2 mal heruntergeladen)
01.09.2023 16:33 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Schrimm
Spezialist



Dabei seit: 16.03.2015
Beiträge: 770
12 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 9,89

Level: 42 [?]
Erfahrungspunkte: 2.630.414
Nächster Level: 3.025.107

394.693 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

Das hatte ich mir am Anfang schon fast gedacht, dass sehr wahrscheinlich ein anderer "Identifier" gebraucht wird und der Hash eventuell nicht ausreicht. Hatte den Gedanken aber wieder verworfen und es auch nicht wirklich getestet.

Verwende diesen Code in der "/acp/lib/class_parse.php":
php:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
function replacemodal($post) {
 global $posts$tpl;

 if(empty($posts['postid'])) $posts['postid'] = "preview";

 $modal="";
 reset($this->modal[0][0]);
 foreach($this->modal[0][0] as $varnr => $val) {
  $id="img#".$posts['postid']."_".$varnr;
  $label="<img class=\"modallabelimg\" src=\"$val[0]\">";
  $link=$val[0];

  eval ("\$modal = \"".$tpl->get("modaltag")."\";");

  $post=str_replace("{".$this->hash."_modalimg_".$varnr."}",$modal,$post);
 }

 reset($this->modal[1][0]);
 foreach($this->modal[1][0] as $varnr => $val) {
  $id="link#".$posts['postid']."_".$varnr;
  $label=$val[1];
  $link=$val[0];

  eval ("\$modal = \"".$tpl->get("modaltag")."\";");

  $post=str_replace("{".$this->hash."_modallink_".$varnr."}",$modal,$post);
 }

 return $post;
}


__________________

01.09.2023 21:25 Schrimm ist offline Beiträge von Schrimm suchen Nehmen Sie Schrimm in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey,

super, jetzt funktioniert es! Vielen Dank! großes Grinsen
01.09.2023 23:03 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey,

sorry, ich habe gestern noch etwas übersehen, was der neue Code ausgelöst hat.

Wenn ich auf "Vorschau" klicke, kommt für jedes Modal, das im Post ist, folgende Meldung:
php:
1:
WarningTrying to access array offset on value of type null in acp/lib/class_parse.php on line 271

Das ist diese Linie:
php:
1:
$id="link#".$posts['postid']."_".$varnr;


Ich habe es selbst versucht, habe es aber nicht korrekt hingekriegt. Kannst du mir da noch einmal helfen?
02.09.2023 16:35 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Schrimm
Spezialist



Dabei seit: 16.03.2015
Beiträge: 770
12 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 9,89

Level: 42 [?]
Erfahrungspunkte: 2.630.414
Nächster Level: 3.025.107

394.693 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

Ich schätze mal, dass es mit der "Vorschau"-Funktion bei der Beitragserstellung/Themenerstelllung zu tun hat?
Benutze einfach den korrigierten Code oben.

__________________

02.09.2023 19:37 Schrimm ist offline Beiträge von Schrimm suchen Nehmen Sie Schrimm in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey,

Es ist mir beim Editieren der Beiträge aufgefallen, aber stimmt, beim Erstellen von Beiträgen ist es auch vorgekommen.

Super, damit kommen die Warnungen nicht mehr, dankeschön. großes Grinsen
02.09.2023 20:36 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hey hey,

mir ist jetzt nach ein paar Monaten zufällig doch noch ein Fehler aufgefallen. Und zwar ist es so, dass das allererste Modal in einem Post auf einer neuen Linie bzw in einem neuen Absatz gemacht wird, wenn es in einem fliessenden Text vorkommt. Ich habe zwei Bilder angefügt, auf denen man es sieht.

Ich habe zuerst gedacht, es handle sich um den gleichen Fehler wie bei dem Post hier:

Zitat:
Original von Schrimm
Hallo,

Zitat:
Original von Patty Halliwell
Etwas Kleines ist mir noch aufgefallen, was ich nicht gefunden habe: Nach dem Modal macht es einen Abstand, den ich nicht wegbekomme.
Zuerst habe ich gedacht, es käme vom "modaltag.tpl"
php:
1:
<label for="checkbox$idclass="modallabel2">&nbsp;</label>
Das ist es aber nicht (da habe ich gesehen, dass der ist, wenn das Modal offen ist). Sonst habe ich aber nirgends Abstände irgendwo im Code gefunden. Wo könnte der sich verstecken?


Das ist eine Nebenerscheinung von "inline"-Elementen.
Versuch es mal mit "display: inline-block;", dann sollte der Abstand verschwinden.
Mittels negativen "margin-right", kannst du den Abstand auch verschwinden lassen.


Jedoch habe ich es mit jedem nur möglichen Element/Value ausprobiert, den ich für "display" habe finden können, der Fehler ist jedoch hartnäckig geblieben, weswegen ich das Gefühl habe, der Fehler müsse irgendwo anders sein.

Könntest du mir da vielleicht nochmals helfen?

Dateianhänge:
png Bild.png (82,03 KB, 62 mal heruntergeladen)
png Link.png (37 KB, 61 mal heruntergeladen)
19.05.2024 21:48 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Schrimm
Spezialist



Dabei seit: 16.03.2015
Beiträge: 770
12 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 9,89

Level: 42 [?]
Erfahrungspunkte: 2.630.414
Nächster Level: 3.025.107

394.693 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

Da läufst du wohl in das Problem, dass der Text im WoltLab Burning Board Lite 1.0.2pl3 eigentlich mittels dem "p"-Element eingefügt wird.

Laut der HTML-Spezifikation sind jedoch Blockelemente innerhalb eines "p"-Elements nicht erlaubt, was bedeutet, dass wenn auf ein "p"-Element ein Blockelement folgt, dass automatisch der schließende Tag eingefügt wird und erst dann das Blockelement.
"div" ist ein solches Blockelement.
Was in deinem Fall zu einer Erzeugung von "<p>Text</p><div>Modal</div>" führt und automatisch, aufgrund der "p"-Eigenschaften einen Zeilenumbruch erzeugt.

Glücklicherweise gibt es jedoch eine Abhilfe, die "span" heißt.
Im Grunde verhalten sich "div" und "span" ähnlich, jedoch der für dich entscheidende Unterschied ist:
  • "div" ist ein Blockelement
  • "span" ist ein Inlineelement

Das bedeutet, wenn du in deinem Template "<div" mit "<span" und "</div>" mit "</span>" ersetzt, sollte es funktionieren, sofern nicht eine andere unerwartete "Stylelimitierung" des Forums greift.

Bei dieser Änderung bietet sich natürlich auch an, dass die "CSS"-Klassennamen und eventuell auch ein paar Eigenschaften, abgeändert werden, da beispielweise "<span class="modaldiv">" hier wohl irreführend wäre.

__________________

24.05.2024 23:29 Schrimm ist offline Beiträge von Schrimm suchen Nehmen Sie Schrimm in Ihre Freundesliste auf
Patty Halliwell Patty Halliwell ist weiblich
Foren As



Dabei seit: 16.06.2019
Beiträge: 77
0 Filebase-Einträge
Alter: 33 Jahre
Herkunft: CH
wBB-Version: wBBLite
PHP-Version: 8.2 (sofern möglich)
MySQL-Version: 5.7 / MyOOS [Dumper]


Mitglied bewerten

Level: 27 [?]
Erfahrungspunkte: 143.465
Nächster Level: 157.092

13.627 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Patty Halliwell


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Guten Abend,

ich habe die 10 "div"s in "span"s umgewandelt (inkl. den CSS-Klassennamen, weil du völlig recht hast wegen der Irreführung) und habe es so probiert und... Es funktioniert einwandfrei! großes Grinsen

Vielen lieben Dank!
27.05.2024 23:46 Patty Halliwell ist offline Beiträge von Patty Halliwell suchen Nehmen Sie Patty Halliwell in Ihre Freundesliste auf
Seiten (2): « vorherige 1 [2] Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
Viktor's Supportboard » Support für das wBB1.1, wBB1.2 und wBB Lite » Fragen/Hilfe/Sonstiges (wBB Lite 1.0) » Modal als BBCode

Impressum | Datenschutz | Fast-Index

Forensoftware: Burning Board 2.3.6, entwickelt von WoltLab® GmbH Design © Tine

Valid XHTML 1.0! Valid CSS! © für wbb2 by Bandy & cback.de Geblockte Angriffe: 2.741
Seo Sidemap Powert by 2Clubradio.de
This site or product includes IP2Location LITE data available from https://lite.ip2location.com.
Viktor's Supportboard, ist " Online " seit 20 Jahren, 341 Tage, 10 Stunden, 51 Minuten und 14 Sekunden