Viktor's Supportboard
Quickmenü
» Start
» Portal
» Kontakt
» Mitglieder
» Team

» Handy-Ansicht


Usermenü

» Registrieren

Login
Benutzername:
Passwort:

(Passwort vergessen?)

Database
» Database

Lizenzshop/Verwaltung
» Lizenzshop/Verwaltung


Allgemeines
» Themen der letzen 24 Stunden
» Beiträge von Heute
» Aktuelle Umfragen
» Themen als gelesen markieren
» Themen ohne Antwort

» F.A.Q
» Regeln
» Impressum
» Datenschutzerklärung

» Linkliste
» Partner
» Statistik

Kostenplichtige Hacks
» VG-Lizenz
» VG-Fotowettbewerb
» VG-Kontaktanzeige
» VG-Literatur-Verwaltung
» VGTreffen/Dater
» VGMusik/Video

Mein Hacks
» VGUser-Leaflet-Map
» VGUser-Google-Map
» VGClub-Map-Google
» User-Map
» Club-Map
» User-Locator
» Club-Locator
» Mitglieder Bilderupload
» VGOnlineList
» Teamspeak Onlineanzeige

Meine Banner
» Meine Banner

Statistik
Beiträge: 138.428 (Täglich: 23,65 )
Themen: 16.136
Mitglieder: 13.152
Neuestes Mitglied: thluckert.
Ausl. d. letzten Minute: 49%
Ausl. d. letzten 5 Minuten: 53%
Ausl. d. letzten 15 Minuten: 51%
Freier Webspace: 1.94 TB
PHP-Version: 7.1.11

Spenden

Partner
Mein Supportboard

MySQLDumper

Forum für Angehörige und Freunde von Krebspatienten

Wetter-Board

Make your Webserver

ABC-des Essens

IC-Netforum

ultimate-funultimate-fun

Steinadler-Bastelstübchen

Webseitenschutz

Werben

Viktor's Supportboard » Programmieren » MySQL und PHP » [Hilfe gesucht] Umlaute » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Umlaute
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg



Umlaute Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo Leute,

Ich habe bei dem Server von all-inkl.com mit Mysql Dumper ein Backup von der your-wbb.de Datenbank gemacht.

Dort Lief Mysql 5.6 und Standard Kodierung war laut MysqlDumper und Phpmyadmin UTF8, also habe ich das Backup mit dem Dumper in UTF8 erstellt.

Nun habe ich es auf dem neuen Server wieder eingespielt, dort läuft auch MYSQL 5.6 und Standartkodierung UTF8.

Leider werden die Umlaute falsch dargestellt.
Die Kodierung der einzelnen Spalten ist laut phpmyadmin passend Latin1 und der charset in der php.ini ist auf ISObla bla also Latin1 eingestellt.

Hat jemand eine Idee?
Ich komm grad leider nicht drauf wo der Haken ist.

PHP Version ist 5.2 und ich plane nicht auf UTF8 umzustellen.
Ich will das weiterhin ganz normal mit Latin1 betreiben.

Hätte ich beim MysqlDumper Latin1 beim Backup auswählen müssen?
Hatte ich aber beim letzten Umzug auch nicht gemacht (von all-inkl.com zu all-inkl.com halt) und hier geht es ja glaube ich auch um den Standard Satz und somit wären die Umlaute dann defekt?

Die Umlaute werden in der Datenbank korrekt angezeigt, nur auf der Webseite nicht.

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von Thx2: 18.11.2016 05:11.

18.11.2016 05:08 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
schnofeli schnofeli ist weiblich
Foren As



Dabei seit: 17.11.2010
Beiträge: 80
0 Filebase-Einträge

wBB-Version: wBB2.3


Mitglied bewerten

Level: 30 [?]
Erfahrungspunkte: 256.168
Nächster Level: 300.073

43.905 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Bei mir hat es geholfen, dass ich in den Sprachvariablen LANG_GLOBAL_ENCODING auf UTF-8 umgestellt habe.

__________________

18.11.2016 18:49 schnofeli ist offline E-Mail an schnofeli senden Homepage von schnofeli Beiträge von schnofeli suchen Nehmen Sie schnofeli in Ihre Freundesliste auf Switzerland
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hi,

Dein Forum läuft dann allerdings komplett mit utf-8 also umgestellt und mit neuer php Version wahrscheinlich auch oder?

Bei mir sind die Spalten der Datenbank latin1 und der php 5.2 default charset ebenfalls.
Ich weiß momentan echt nicht was falsch ist ich hab die dB mal in latin1 importiert der Fehler bleibt.

Ich schau zuhause ob die Umlaute weiterhin korrekt in der Datenbank stehen und nur auf der Webseite falsch ausgegeben werden.

Ich tippe auf php oder MySQL config, Tipps?
18.11.2016 19:21 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Viktor   Zeige Viktor auf Karte Viktor ist männlich
Administrator


images/avatars/avatar-15762.jpg

Zeige Viktor auf Karte
Dabei seit: 15.08.2003
Beiträge: 29.893
363 Filebase-Einträge
Alter: 62 Jahre
Herkunft: NRW
wBB-Version: wBB2.3
PHP-Version: 7.1.11
MySQL-Version: 5.5.59-0+deb8u1
Wo bist du gehostet?: eigener Server

Bewertung: 
279 Bewertung(en) - Durchschnitt: 9,47

Level: 68 [?]
Erfahrungspunkte: 174.958.538
Nächster Level: 176.283.333

1.324.795 Erfahrungspunkt(e) für den nächsten Levelanstieg



RE: Umlaute Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Zitat:
Original von Thx2

Hätte ich beim MysqlDumper Latin1 beim Backup auswählen müssen?


Hallo,

ja da das wBB2 nur unter Latain1 läuft. fröhlich

Gruß
Viktor Augenzwinkern

__________________
Ein kluger Mann widerspricht keiner Frau. Er wartet, bis sie es selbst tut.


... beim Käfer (WBB2) konnte man noch selber schrauben,
beim neuen Golf (WBB3) muß man fast schon in die Werkstatt wenn man das "Wischwasser" nachfüllen muss!


Da fast keiner mehr hier Postet gibt es ab sofort keinen Support mehr per PN.

18.11.2016 19:42 Viktor ist offline E-Mail an Viktor senden Homepage von Viktor Beiträge von Viktor suchen Nehmen Sie Viktor in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Ich hab die Datenbank nun nochmal als latin1 exportiert und importiert gleicher Fehler.
Ich bin in ca. 30 min zuhause dann schau ich ob die Umlaute in der Datenbank noch immer korrekt sind.

Die einzelnen Spalten sind übrigens immer latin1.

Muss ich bei mysql noch irgendwo eine default Einstellung anpassen?
18.11.2016 19:48 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Viktor   Zeige Viktor auf Karte Viktor ist männlich
Administrator


images/avatars/avatar-15762.jpg

Zeige Viktor auf Karte
Dabei seit: 15.08.2003
Beiträge: 29.893
363 Filebase-Einträge
Alter: 62 Jahre
Herkunft: NRW
wBB-Version: wBB2.3
PHP-Version: 7.1.11
MySQL-Version: 5.5.59-0+deb8u1
Wo bist du gehostet?: eigener Server

Bewertung: 
279 Bewertung(en) - Durchschnitt: 9,47

Level: 68 [?]
Erfahrungspunkte: 174.958.538
Nächster Level: 176.283.333

1.324.795 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Zitat:
Original von Thx2
Ich hab die Datenbank nun nochmal als latin1 exportiert und importiert gleicher Fehler.
Ich bin in ca. 30 min zuhause dann schau ich ob die Umlaute in der Datenbank noch immer korrekt sind.

Die einzelnen Spalten sind übrigens immer latin1.

Muss ich bei mysql noch irgendwo eine default Einstellung anpassen?


Hallo,

jo da gibt es immer Problem mit dem Export und Import. unglücklich

Meine Datenbank ist "latin1_swedish_ci" und die Tabellen auch "latin1_swedish_ci".

Gruß
Viktor Augenzwinkern

__________________
Ein kluger Mann widerspricht keiner Frau. Er wartet, bis sie es selbst tut.


... beim Käfer (WBB2) konnte man noch selber schrauben,
beim neuen Golf (WBB3) muß man fast schon in die Werkstatt wenn man das "Wischwasser" nachfüllen muss!


Da fast keiner mehr hier Postet gibt es ab sofort keinen Support mehr per PN.

18.11.2016 20:17 Viktor ist offline E-Mail an Viktor senden Homepage von Viktor Beiträge von Viktor suchen Nehmen Sie Viktor in Ihre Freundesliste auf Germany
schnofeli schnofeli ist weiblich
Foren As



Dabei seit: 17.11.2010
Beiträge: 80
0 Filebase-Einträge

wBB-Version: wBB2.3


Mitglied bewerten

Level: 30 [?]
Erfahrungspunkte: 256.168
Nächster Level: 300.073

43.905 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Zitat:
Original von Viktor
Hallo,

jo da gibt es immer Problem mit dem Export und Import. unglücklich

Meine Datenbank ist "latin1_swedish_ci" und die Tabellen auch "latin1_swedish_ci".

Gruß
Viktor Augenzwinkern


Hatte ich bei mir auch erfolglos probiert. Bei mir, resp. dem Server-Hoster ist Maria-DB drauf. Könnte ev. auch daran liegen. UTF-8 tut jedenfalls und man muss halt dann so das eine oder andere umprogrammieren, damit das WBB korrekt läuft.

__________________

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von schnofeli: 18.11.2016 20:31.

18.11.2016 20:31 schnofeli ist offline E-Mail an schnofeli senden Homepage von schnofeli Beiträge von schnofeli suchen Nehmen Sie schnofeli in Ihre Freundesliste auf Switzerland
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Bei mir läuft Mysql 5.6

Mysqldumper sagt folgendes:
Zitat:

character_set_client utf8
character_set_connection utf8
character_set_database utf8
character_set_filesystem binary
character_set_results utf8
character_set_server utf8
character_set_system utf8
character_sets_dir /usr/local/share/charsets/
collation_connection utf8_general_ci
collation_database utf8_general_ci
collation_server utf8_general_ci


Zumindest die ersten Beiden waren bei all-inkl.com auch utf8, aber ich glaube 2 von diesen werten (mindestens) waren latin1.

Liegt es hieran?
Welche Einstellungen muss ich ggf. ändern?

Auch ein in Latin1 exportiertes und Importiertes Backup ändert momentan nichts, die Umlaute stehen aber in der Datenbank richtig drin und die einzelnen tabellen/spalten sind auch in latin1_swedish_ci kodiert/angelegt.
18.11.2016 20:52 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hier noch der Anfang meines Backups in latin 1

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
-- Status:88:9594109:MP_0:usr_p382385_1:php:1.24.4::5.6.33:1:::latin1:EXTINFO
--
-- TABLE-INFO
-- TABLE|bb1_access|0|1024|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_acpmenuitemgroups|22|4668|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_acpmenuitemgroupscount|20|2348|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_acpmenuitems|70|8744|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_acpmenuitemscount|28|2468|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_acprules|1|16904|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_adminsessions|80|18372|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_announcements|20|2228|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_applications|0|1024|2016-11-18 05:23:58|MyISAM
-- TABLE|bb1_attachments|27826|2550824|2016-11-18 05:24:36|MyISAM
-- TABLE|bb1_avatars|2331|133164|2016-11-18 05:24:40|MyISAM
-- TABLE|bb1_bbcodes|16|5684|2016-11-18 05:24:40|MyISAM
-- TABLE|bb1_boards|94|47360|2016-11-18 05:24:40|MyISAM
-- TABLE|bb1_boardvisit|3|3111|2016-11-18 05:24:40|MyISAM
-- TABLE|bb1_contact_keys|85|3748|2016-11-18 14:09:45|MyISAM
-- TABLE|bb1_contacts|17|9396|2016-11-18 05:24:41|MyISAM
-- TABLE|bb1_designelements|840|83324|2016-11-18 05:24:42|MyISAM
-- TABLE|bb1_designpacks|8|2248|2016-11-18 05:24:42|MyISAM
-- TABLE|bb1_events|5|7524|2016-11-18 05:24:42|MyISAM
-- TABLE|bb1_folders|59|4436|2016-11-18 05:24:42|MyISAM
-- TABLE|bb1_forensmilies|34|4016|2016-11-18 05:24:42|MyISAM
-- TABLE|bb1_groupcombinations|37|692356|2016-11-18 05:24:43|MyISAM
-- TABLE|bb1_groupleaders|0|1024|2016-11-18 05:24:43|MyISAM
-- TABLE|bb1_groups|10|2584|2016-11-18 05:24:43|MyISAM
-- TABLE|bb1_groupvalues|2360|89520|2016-11-18 05:24:46|MyISAM
-- TABLE|bb1_groupvariablegroups|34|3092|2016-11-18 05:24:46|MyISAM
-- TABLE|bb1_groupvariables|236|26392|2016-11-18 05:24:47|MyISAM
-- TABLE|bb1_icons|18|2992|2016-11-18 05:24:47|MyISAM
-- TABLE|bb1_introduces|23|7124|2016-11-18 05:24:47|MyISAM
-- TABLE|bb1_ip_land_database|54776|2631528|2016-11-18 05:25:59|MyISAM
-- TABLE|bb1_languagecats|61|6436|2016-11-18 05:25:59|MyISAM
-- TABLE|bb1_languagepacks|1|3092|2016-11-18 05:25:59|MyISAM
-- TABLE|bb1_languages|3912|796296|2016-11-18 05:26:05|MyISAM
-- TABLE|bb1_linkus|6|2968|2016-11-18 05:26:05|MyISAM
-- TABLE|bb1_mailqueue|56258|3390624|2016-11-18 05:27:19|MyISAM
-- TABLE|bb1_mails|1|2424|2016-11-18 05:27:19|MyISAM
-- TABLE|bb1_moderators|0|1024|2016-11-18 05:27:19|MyISAM
-- TABLE|bb1_optiongroups|22|2508|2016-11-18 05:27:19|MyISAM
-- TABLE|bb1_options|255|40388|2016-11-18 05:27:20|MyISAM
-- TABLE|bb1_permissions|387|22374|2016-11-18 05:27:21|MyISAM
-- TABLE|bb1_polloptions|1321|77472|2016-11-18 05:27:23|MyISAM
-- TABLE|bb1_polls|237|21160|2016-11-18 05:27:24|MyISAM
-- TABLE|bb1_postcache|376|361496|2016-11-18 05:27:24|MyISAM
-- TABLE|bb1_posts|455029|213338532|2016-11-18 05:37:58|MyISAM
-- TABLE|bb1_privatemessage|46224|51134808|2016-11-18 05:39:08|MyISAM
-- TABLE|bb1_privatemessagereceipts|46388|2762292|2016-11-18 05:40:11|MyISAM
-- TABLE|bb1_profilefields|5|2736|2016-11-18 05:40:11|MyISAM
-- TABLE|bb1_ranks|8|3620|2016-11-18 05:40:11|MyISAM
-- TABLE|bb1_register_keys|275|11720|2016-11-18 05:40:12|MyISAM
-- TABLE|bb1_searchs|4|44664|2016-11-18 14:42:37|MyISAM
-- TABLE|bb1_sessions|93|248760||MEMORY
-- TABLE|bb1_smilies|44|4576|2016-11-18 05:40:12|MyISAM
-- TABLE|bb1_stats|1|1045|2016-11-18 05:40:12|MyISAM
-- TABLE|bb1_styles|9|2348|2016-11-18 05:40:12|MyISAM
-- TABLE|bb1_subscribeboards|145|5691|2016-11-18 05:40:13|MyISAM
-- TABLE|bb1_subscribethreads|16834|471894|2016-11-18 05:40:35|MyISAM
-- TABLE|bb1_templatepacks|8|112560|2016-11-18 05:40:36|MyISAM
-- TABLE|bb1_templates|540|1717052|2016-11-18 05:40:37|MyISAM
-- TABLE|bb1_threads|64181|8834060|2016-11-18 05:42:05|MyISAM
-- TABLE|bb1_threads1|64485|8931224|2016-11-18 05:43:34|MyISAM
-- TABLE|bb1_threadvisit|45210|1887186|2016-11-18 14:42:37|MyISAM
-- TABLE|bb1_user2groups|68620|2797676|2016-11-18 05:46:03|MyISAM
-- TABLE|bb1_userfields|67932|2588692|2016-11-18 05:47:32|MyISAM
-- TABLE|bb1_users|67932|20544584|2016-11-18 10:46:53|MyISAM
-- TABLE|bb1_votes|25645|1666028|2016-11-18 05:49:46|MyISAM
-- TABLE|bb1_wiwbots|64|5832|2016-11-18 05:49:46|MyISAM
-- TABLE|bb1_wordlist|339808|18943984|2016-11-18 05:57:12|MyISAM
-- TABLE|bb1_wordmatch|8090886|220191292|2016-11-18 08:52:10|MyISAM
-- TABLE|db0_entries|2690|2543688|2016-11-18 08:52:15|MyISAM
-- TABLE|db1_board2databases|63|2615|2016-11-18 08:52:15|MyISAM
-- TABLE|db1_databases|63|9788|2016-11-18 08:52:15|MyISAM
-- TABLE|db1_entries|2402|2099292|2016-11-18 08:52:19|MyISAM
-- TABLE|db1_files|2407|140932|2016-11-18 08:52:23|MyISAM
-- TABLE|db1_mailabos|0|1024|2016-11-18 08:52:23|MyISAM
-- TABLE|db1_permissions|8|2208|2016-11-18 08:52:23|MyISAM
-- TABLE|lp1_cats|28|10108|2016-11-18 08:52:23|MyISAM
-- TABLE|lp1_comments|0|1024|2016-11-18 08:52:23|MyISAM
-- TABLE|lp1_global|1|2600|2016-11-18 08:53:44|MyISAM
-- TABLE|lp1_ipblock|1|2076|2016-11-18 08:52:23|MyISAM
-- TABLE|lp1_klblock|0|1024|2016-11-18 08:52:23|MyISAM
-- TABLE|lp1_lastactivity|4628|96948|2016-11-18 08:52:29|MyISAM
-- TABLE|lp1_links|205|79348|2016-11-18 08:53:44|MyISAM
-- TABLE|lp1_linkvisit|28249|852613|2016-11-18 08:53:07|MyISAM
-- TABLE|lp1_stats|9|2309|2016-11-18 14:42:39|MyISAM
-- TABLE|lp1_votes|1093|93769|2016-11-18 08:53:09|MyISAM
-- TABLE|lp1_votes_ips|0|1024|2016-11-18 08:53:09|MyISAM
-- TABLE|lp1_wwo|1|2057|2016-11-18 08:53:09|MyISAM
-- TABLE|lp1_wwo_rec|1|3085|2016-11-18 08:53:09|MyISAM
-- EOF TABLE-INFO
--
-- Dump by MySQLDumper 1.24.4 (http://mysqldumper.net)
/*!40101 SET NAMES 'latin1' */;
SET FOREIGN_KEY_CHECKS=0;
-- Dump created: 2016-11-18 14:42

--
-- Create Table `bb1_access`
--

DROP TABLE IF EXISTS `bb1_access`;
CREATE TABLE `bb1_access` (
  `boardid` int(11) unsigned NOT NULL DEFAULT '0',
  `userid` int(11) unsigned NOT NULL DEFAULT '0',
  `can_view_board` tinyint(1) NOT NULL DEFAULT '-1',
  `can_enter_board` tinyint(1) NOT NULL DEFAULT '-1',
  `can_read_thread` tinyint(1) NOT NULL DEFAULT '-1',
  `can_start_topic` tinyint(1) NOT NULL DEFAULT '-1',
  `can_reply_topic` tinyint(1) NOT NULL DEFAULT '-1',
  `can_post_poll` tinyint(1) NOT NULL DEFAULT '-1',
  `can_upload_attachments` tinyint(1) NOT NULL DEFAULT '-1',
  `can_download_attachments` tinyint(1) NOT NULL DEFAULT '-1',
  `can_post_without_moderation` tinyint(1) NOT NULL DEFAULT '-1',
  `can_close_own_topic` tinyint(1) NOT NULL DEFAULT '-1',
  `can_use_search` tinyint(1) NOT NULL DEFAULT '-1',
  `can_vote_poll` tinyint(1) NOT NULL DEFAULT '-1',
  `can_rate_thread` tinyint(1) NOT NULL DEFAULT '-1',
  `can_del_own_post` tinyint(1) NOT NULL DEFAULT '-1',
  `can_edit_own_post` tinyint(1) NOT NULL DEFAULT '-1',
  `can_del_own_topic` tinyint(1) NOT NULL DEFAULT '-1',
  `can_edit_own_topic` tinyint(1) NOT NULL DEFAULT '-1',
  `can_move_own_topic` tinyint(1) NOT NULL DEFAULT '-1',
  `can_use_post_html` tinyint(1) NOT NULL DEFAULT '-1',
  `can_use_post_bbcode` tinyint(1) NOT NULL DEFAULT '-1',
  `can_use_post_smilies` tinyint(1) NOT NULL DEFAULT '-1',
  `can_use_post_icons` tinyint(1) NOT NULL DEFAULT '-1',
  `can_use_post_images` tinyint(1) NOT NULL DEFAULT '-1',
  PRIMARY KEY (`userid`,`boardid`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;


Habe das selbe natürlich auch mit UTF8 gemacht (außer bei den einzelnen Tabellen da war der Charset immer Latin1)

Also der Fehler liegt denke ich in den Einstellungen von meinem letzten posting, vllt. weiß ja wer wo genau.
18.11.2016 21:08 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Viktor   Zeige Viktor auf Karte Viktor ist männlich
Administrator


images/avatars/avatar-15762.jpg

Zeige Viktor auf Karte
Dabei seit: 15.08.2003
Beiträge: 29.893
363 Filebase-Einträge
Alter: 62 Jahre
Herkunft: NRW
wBB-Version: wBB2.3
PHP-Version: 7.1.11
MySQL-Version: 5.5.59-0+deb8u1
Wo bist du gehostet?: eigener Server

Bewertung: 
279 Bewertung(en) - Durchschnitt: 9,47

Level: 68 [?]
Erfahrungspunkte: 174.958.538
Nächster Level: 176.283.333

1.324.795 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

du musst erst die Datenbank in "latin1_swedish_ci" erstellen. fröhlich

Wenn die schon UTF-8 ist geht es nicht soweit ich weiß. Augen rollen

Vielleicht so ändern. verwirrt

Zitat:

ALTER DATABASE `db-name`
DEFAULT CHARACTER SET latin1
COLLATE latin1_swedish_ci;


https://dev.mysql.com/doc/refman/5.6/en/...plications.html

Gruß
Viktor Augenzwinkern

__________________
Ein kluger Mann widerspricht keiner Frau. Er wartet, bis sie es selbst tut.


... beim Käfer (WBB2) konnte man noch selber schrauben,
beim neuen Golf (WBB3) muß man fast schon in die Werkstatt wenn man das "Wischwasser" nachfüllen muss!


Da fast keiner mehr hier Postet gibt es ab sofort keinen Support mehr per PN.

18.11.2016 21:12 Viktor ist offline E-Mail an Viktor senden Homepage von Viktor Beiträge von Viktor suchen Nehmen Sie Viktor in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Ich hab die Datenbank nochmal komplett gelöscht und eine neue Angelegt (Dabei kann man allerdings nur das passwort angeben und nicht ob ich sie in Latin1 oder Utf8 haben möchte.)

Nun habe ich deinen code ausgeführt und bekomme zurück:
"MySQL lieferte ein leeres Resultat zurück (d.h. null Datensätze). (Die Abfrage dauerte 0.0015 Sekunden.)"

Soll ich erst den Dump einspielen und das dann machen?
Sicher das ich nicht die Einstellungen von Mysql ändern muss?

Zitat:

character_set_client utf8
character_set_connection utf8
character_set_database utf8
character_set_filesystem binary
character_set_results utf8
character_set_server utf8
character_set_system utf8
character_sets_dir /usr/local/share/charsets/
collation_connection utf8_general_ci
collation_database utf8_general_ci
collation_server utf8_general_ci


Also quasi wie wenn ich die php.ini bearbeiten würde die Konfigurationsdatei von mysql?

Ich werd nun einfach nochmal nen Backup einspielen und dann deinen Code ausführen, sollte das nicht helfen muss ich mich wohl an Mittwald wenden sollte keiner mehr helfen können.
18.11.2016 21:21 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Viktor   Zeige Viktor auf Karte Viktor ist männlich
Administrator


images/avatars/avatar-15762.jpg

Zeige Viktor auf Karte
Dabei seit: 15.08.2003
Beiträge: 29.893
363 Filebase-Einträge
Alter: 62 Jahre
Herkunft: NRW
wBB-Version: wBB2.3
PHP-Version: 7.1.11
MySQL-Version: 5.5.59-0+deb8u1
Wo bist du gehostet?: eigener Server

Bewertung: 
279 Bewertung(en) - Durchschnitt: 9,47

Level: 68 [?]
Erfahrungspunkte: 174.958.538
Nächster Level: 176.283.333

1.324.795 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

es wird ja mit dem Befehl nur die Datenbank umgeändert und da liefert MySQL nichts zurück.

Wenn du Das gemacht hast musst du dein Backup mit Latein einspielen. fröhlich

So hoffe ich das es klappt. Augen rollen

Da ich immer auf der Konsole ein Backup mit "mysqldump" mache ist immer alles richtig. fröhlich

Gruß
Viktor Augenzwinkern

__________________
Ein kluger Mann widerspricht keiner Frau. Er wartet, bis sie es selbst tut.


... beim Käfer (WBB2) konnte man noch selber schrauben,
beim neuen Golf (WBB3) muß man fast schon in die Werkstatt wenn man das "Wischwasser" nachfüllen muss!


Da fast keiner mehr hier Postet gibt es ab sofort keinen Support mehr per PN.

18.11.2016 21:33 Viktor ist offline E-Mail an Viktor senden Homepage von Viktor Beiträge von Viktor suchen Nehmen Sie Viktor in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Ich habe mir ein frisches WBB2 geholt.
PHP 5.2 latin1 eingestellt.
Datenbank erstellt und das WBB installiert.
ANSCHLIEßEND deinen Code ausgeführt.
Ergebnis: äöüß! statt äöüß! z.b.

Darauf hin habe ich den inhalt der DB gelöscht.
Nochmal deinen Code ausgeführt.
WBB auch nochmal gelöscht, nochmal hochgeladen und installiert.
Ergebnis: ? statt ü z.b. (Wird auch in der Datenbank als ? gespeichert)

Der Fehler hat sich nun also geändert, ist aber noch immer nicht weg.
Wenn man übrigens deinen code vor der installation nicht ausführt dann werden die Tabellen in utf8 installiert weil in der structure.sql nichts anderes festgelegt ist.

hast du noch einen tipp?
Ich probier das problem jetzt erstmal mit einem frischen wbb zu lösen da ich dort keine 500mb große Datenbank importieren muss jedesmal.

Dieser Beitrag wurde 4 mal editiert, zum letzten Mal von Thx2: 18.11.2016 22:05.

18.11.2016 21:57 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Insofern ich beim zweiten beispiel nun in der DB die ? durch umlaute ersetze werden die korrekt abgespeichert aber auf der Webseite wieder falsch ausgegeben: äöüß
18.11.2016 21:59 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Viktor   Zeige Viktor auf Karte Viktor ist männlich
Administrator


images/avatars/avatar-15762.jpg

Zeige Viktor auf Karte
Dabei seit: 15.08.2003
Beiträge: 29.893
363 Filebase-Einträge
Alter: 62 Jahre
Herkunft: NRW
wBB-Version: wBB2.3
PHP-Version: 7.1.11
MySQL-Version: 5.5.59-0+deb8u1
Wo bist du gehostet?: eigener Server

Bewertung: 
279 Bewertung(en) - Durchschnitt: 9,47

Level: 68 [?]
Erfahrungspunkte: 174.958.538
Nächster Level: 176.283.333

1.324.795 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Zitat:
Original von Thx2
Insofern ich beim zweiten beispiel nun in der DB die ? durch umlaute ersetze werden die korrekt abgespeichert aber auf der Webseite wieder falsch ausgegeben: äöüß


Hallo,

ich habe noch ein Script gefunden was das beheben soll. fröhlich

Ich habe es noch nicht getestet da ich es nicht brauchte. fröhlich

Gruß
Viktor Augenzwinkern

Dateianhänge:
txt fix_umlaute.php.txt (23,10 KB, 6 mal heruntergeladen)
txt readme.txt (1,34 KB, 6 mal heruntergeladen)


__________________
Ein kluger Mann widerspricht keiner Frau. Er wartet, bis sie es selbst tut.


... beim Käfer (WBB2) konnte man noch selber schrauben,
beim neuen Golf (WBB3) muß man fast schon in die Werkstatt wenn man das "Wischwasser" nachfüllen muss!


Da fast keiner mehr hier Postet gibt es ab sofort keinen Support mehr per PN.

18.11.2016 22:06 Viktor ist offline E-Mail an Viktor senden Homepage von Viktor Beiträge von Viktor suchen Nehmen Sie Viktor in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Also wenn ich ne Datenbank anlege, deinen Code ausführe und dann das WBB installiere was in ? resultiert, bringt das script nichts.

Mache ich das erst danach dann werden die Tabellen alle in utf8 angelegt und das kann ja so oder so nicht funktionieren.

Ich denke das liegt an den Einstellungen von Mysql am Server.
vllt. können die mir ja noch zusätzlich Mysql 5.5 installieren und dort alles auf latin1 standart/default mäßig einstellen, ich denke das sollte das Problem lösen.

Bei php 5.2 ist ja der default charset eh auf latin1 eingestellt und 5.2 arbeitet ja sowieso standardmäßig mit latin1. Daran sollte es wohl nicht liegen.

Was mich wundert ist ja das die Umlaute in den Template einwandfrei angezeigt werden? Auch wenn ich im ACP ein TEmplate bearbeite und da Umlaute reinschreibe funktioniert das wunderbar.

Warum ist das so?
Ich denke ich werde da wohl den Hoster mal kontaktieren müssen die werden schon wissen wie sie ihren sever eingestellt haben und woran das liegt.
18.11.2016 22:23 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Viktor   Zeige Viktor auf Karte Viktor ist männlich
Administrator


images/avatars/avatar-15762.jpg

Zeige Viktor auf Karte
Dabei seit: 15.08.2003
Beiträge: 29.893
363 Filebase-Einträge
Alter: 62 Jahre
Herkunft: NRW
wBB-Version: wBB2.3
PHP-Version: 7.1.11
MySQL-Version: 5.5.59-0+deb8u1
Wo bist du gehostet?: eigener Server

Bewertung: 
279 Bewertung(en) - Durchschnitt: 9,47

Level: 68 [?]
Erfahrungspunkte: 174.958.538
Nächster Level: 176.283.333

1.324.795 Erfahrungspunkt(e) für den nächsten Levelanstieg



Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Hallo,

jo mache MySQL-Server sind auf UTF-8 einstellt. unglücklich

Vielleicht die Sprachvariable "LANG_GLOBAL_ENCODING" mal ändern von "iso-8859-1" auf "utf-8". Augen rollen

Gruß
Viktor Augenzwinkern

__________________
Ein kluger Mann widerspricht keiner Frau. Er wartet, bis sie es selbst tut.


... beim Käfer (WBB2) konnte man noch selber schrauben,
beim neuen Golf (WBB3) muß man fast schon in die Werkstatt wenn man das "Wischwasser" nachfüllen muss!


Da fast keiner mehr hier Postet gibt es ab sofort keinen Support mehr per PN.

18.11.2016 22:36 Viktor ist offline E-Mail an Viktor senden Homepage von Viktor Beiträge von Viktor suchen Nehmen Sie Viktor in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Dann lass ich lieber den Mysql Server umstellen
Sonst muss ich ja alles auf UTF-8 umändern ^^
18.11.2016 22:39 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Zitat:
Geradezu vorbildlich ist die Zeichensatzunterstützung von MySQL - allerdings erst seit Version 4.1. Sie können nicht nur für den Server oder für eine Datenbank den gewünschten Zeichensatz einstellen, sondern auch für jede Tabelle und sogar für jede einzelne Spalte einer Tabelle.


Also damit ist es ja eindeutig.
Der SERVER ist auf UTF8 eingestellt und das kann ich ohne die Konfigurationsdatei zu bearbeiten auch nicht umstellen, das soll also der Hoster für mich machen. smile

Ticket send out. smile

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Thx2: 18.11.2016 23:11.

18.11.2016 23:11 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Thx2
New Kids Junge


Dabei seit: 17.02.2010
Beiträge: 491
0 Filebase-Einträge

wBB-Version: wBBLite

Bewertung: 
9 Bewertung(en) - Durchschnitt: 3,33

Level: 39 [?]
Erfahrungspunkte: 1.706.253
Nächster Level: 1.757.916

51.663 Erfahrungspunkt(e) für den nächsten Levelanstieg

Themenstarter Thema begonnen von Thx2


Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Ende der Seite springen Zum Anfang der Seite springen

Zitat:
Original von Viktor
Hallo,

jo mache MySQL-Server sind auf UTF-8 einstellt. unglücklich

Vielleicht die Sprachvariable "LANG_GLOBAL_ENCODING" mal ändern von "iso-8859-1" auf "utf-8". Augen rollen

Gruß
Viktor Augenzwinkern


Ich hab das übrigens mal getestet, funktioniert.
Die Datenbank ist hierbei in Latin1 und der Charset vom WBB/Sprachvariable auf utf-8 und es funktioniert trotzdem!

Das kann ja nur bedeuten das der Mysql Server in UTF-8 ist und auf Latin1 umgestellt werden sollte oder?
Ich mein Apache/Webserver wird ja nicht schuld sein das WBB sagt ja welche Kodierung es möchte und PHP 5.2 ist ja auch Standardmäßig auf Latin1 eingestellt.

Dieser Beitrag wurde 3 mal editiert, zum letzten Mal von Thx2: 19.11.2016 01:37.

19.11.2016 01:29 Thx2 ist offline E-Mail an Thx2 senden Beiträge von Thx2 suchen Nehmen Sie Thx2 in Ihre Freundesliste auf Germany
Seiten (2): [1] 2 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
Viktor's Supportboard » Programmieren » MySQL und PHP » [Hilfe gesucht] Umlaute

Impressum | Datenschutz | Fast-Index

Forensoftware: Burning Board 2.3.6, entwickelt von WoltLab® GmbH Design © Tine

Valid XHTML 1.0! Valid CSS! Die letzten Themen Die letzten Beiträge © für wbb2 by Bandy & cback.de Geblockte Angriffe: 3.323
Seo Sidemap Powert by 2Clubradio.de
Viktor's Supportboard, ist " Online " seit 16 Jahren, 8 Tage, 19 Stunden, 49 Minuten und 56 Sekunden